Etheruem

Truffleでmigrateがコケる時

TruffleでRopstenテストネットにデプロイをするときに、
以下のエラーが発生。

Error:  *** Deployment Failed ***

"Migrations" -- invalid sender.

    at /path/to/project/node_modules/truffle/build/webpack:/packages/deployer/src/deployment.js:365:1
    at process._tickCallback (internal/process/next_tick.js:68:7)
(node:54358) ExperimentalWarning: The fs.promises API is experimental

githubでエラーを調べてみるとどうやら@truffle/hdwallet-providerの最新バージョンが引き起こしているバグだそう。
https://github.com/trufflesuite/truffle/issues/3936

なので、1.2.2のバージョンへダウングレードする必要がある。
以下のコマンドで実行。

$ npm remove @truffle/hdwallet-provider 
$ npm install @truffle/hdwallet-provider@1.2.2 --save
ABOUT ME
りょう
○玉県在住 | 29歳 駆け出しエンジニアやエンジニアになりたい人向けに役立つ情報発信中 とある中小ベンチャーのバックエンドエンジニアです。 経理やサッカー関連の仕事をしていたが、ある日突然webサイト作成に興味を持ち、そこから猛勉強をしてエンジニアになりました。 未経験から2年で独立してフリーランスに 現在もフルタイムで働きつつ、副業でクライアント複数社と契約 Go | GCP | サッカー / フットサル | お肉 | 謎解き | 将棋